Discovery 2017

↓ Advertise on DISCO5.CO.UK ↓

  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    Forward alert not available

    A few weeks ago I had a forward alert not available message on the dashboard twice in two days. Car would not move without restarting. Both occasions were on busy roads after stopping in traffic.

    Car then had an engine management issue and has been in to the dealer for a software update (PCM) and LR assist also previously updated the camera software.

    Today the forward alert issue recurred at a roundabout after exiting the motorway. With some friends this time, hill descent, aeb and stability control all not available. Car would not move until put into park and back into drive.

    Anyone seen this before?

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • klinkhammer
    Member Since: 14 Jun 2018
    Location: Dingwall
    Posts: 26
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Corris Grey

    Similar thing happened to be 3 weeks ago. At traffic lights engine stopped and in drive, lights change and I apply accelerator and nothing happened, put in park then changed to drive and still nothing. Switched off ignition and back on again selected drive and everything as normal, not done it since.

    This was about a week after software update.
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    Cheers Klinkhammer.

    A few hours after my post, I decided to bite the bullet and call out LR Assist in the full expectation it would end up in a dealer.

    1410 LR Assist arrive
    1510 LR Assist depart, yep should go to a dealer
    1550 a call to say they have a car at a dealer 4 miles away
    1700 leave dealer in the loaner

    Great service from Assist. Long chat with the tech on Thursday describing the symptoms. Now waiting to hear what they can find.

    Second time in a HSE Lux loaner in the past month, but this time it’s a 2.0. Makes for an interesting comparison with my SDV6.

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • klinkhammer
    Member Since: 14 Jun 2018
    Location: Dingwall
    Posts: 26
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Corris Grey

    Equilibrium40

    What version of the software are you running? It was after the change to 19c that I had the fault.
  • klinkhammer
    Member Since: 14 Jun 2018
    Location: Dingwall
    Posts: 26
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Corris Grey

    Cut and pasted and didn't notice it had added the 40.
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    No worries re the 40 Smile

    I think it’s running version 19b. I haven’t got around to the OTA update yet. I will maybe ask the dealer to check when they update me. Good idea to check!

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • JST
    Member Since: 29 Jan 2018
    Location: Taunton
    Posts: 16
    United Kingdom 

    are they not all battery linked issues. low bat or poor connectors, some of those used to come up faults across a range of jlr products
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    Some sort of sensor, described by the service advisor as a speed sensor - on back order so without my car for another week or two. Not great.

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • JRB
    Member Since: 20 Aug 2019
    Location: North Wales
    Posts: 4
    United Kingdom 
    2018 Discovery SDV6 HSE Lux Carpathian Grey

    had the same experience with a multitude of what i considered to be spurious warnings flash up and loss of functionality of various driver aids . All seemed to start after a software upgrade late last year.
    The repairing dealership have been extremely good so far with provision of car in mines place .
    Also advised that " one of " the FWD sensors is at fault and that it is on back order .
    Has anyone had this issue resolved ?
    To me it sounds like more of a software issue ..................................... why should the sensor be causing these problems after update when previously not causing the symptoms ....... is it coincidence?
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    We are in the same boat JRB. Mine is awaiting the sensor on back order as well. The module behind the front bumper, presumably radar and camera?

    The problem started on mine before any software update though, I have not enabled OTA updates.

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • JRB
    Member Since: 20 Aug 2019
    Location: North Wales
    Posts: 4
    United Kingdom 
    2018 Discovery SDV6 HSE Lux Carpathian Grey

    Maybe it is pure coincidence , incredible that there should be a long delay on what you would think is a generic sensor , no idea if it is an OEM part or from third party and adapted by JLR.

    I really love the car but it has been a PITA recently.

    Oh well , first world problems eh .

    Incidentally the same colour and trim level as yours although a late 2018 ........ bloody gorgeous car !
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    Apparently a third party component and listed on the Britpart website (but I don’t have the part number).

    Does seem odd for them to randomly fail.

    I know what you mean about a gorgeous car, I’m missing mine like hell! Will make me appreciate it all the more once it’s back.

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • Craigp
    Member Since: 09 Nov 2016
    Location: Hull
    Posts: 540
    England 

    Have you considered giving the car a clean. See link and conclusion of fault.

    https://www.disco5forums.co.uk/viewtopic.php?f=11&t=4588
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 250
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    Cheers Craig. Interesting! Mine had gone over three months without a wash before the first fault - funnily enough a thorough cleanby myself was an intention for xmas, but it ended up at the dealer instead. The first dealer did clean it, but fault recurred, they won’t have got near bearings and suchlike though. Mine doesn’t go off-road, but if the fault recurs I will get busy with the jet wash before giving them another go.

    Drives MY2020 HSE Luxury SDV6 in Carpathian Grey/Glacier
  • Forum Permissions
  • You cannot create new threads in this forum
    You cannot reply to threads in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot vote in polls in this forum
All times are GMT DISCO5.CO.UK © 2016 - 2020 Futuranet Ltd DISCO5.CO.UK RSS Feed - All Forums 
DISCO5.CO.UK is independent and not affiliated to Jaguar Land Rover.
Switch to the mobile site