Discovery 2017

↓ Advertise on DISCO5.CO.UK ↓

  • Hessel
    Member Since: 10 Feb 2017
    Location: Worcetershire
    Posts: 18
    England 
    2019 Discovery SDV6 HSE Lux Santorini Black

    Car dead.

    Well went out in the car this afternoon and stop at traffic lights then all electronics and stop dead. Tried the usual lock car to reboot nothing happened unable to lock car also hazards lights won’t Even work. Called Landrover assistant. 1. 5 hours later AA roles up. This time I’m causing Massive traffic issues😣. Any way AA man checked battery all seems ok.then plugged his battery buster pack to main battery and then had life back in to motor. And he’s say I’ll follow you home. Then bang car all dead again. As before placed is battery pact to main battery in back then car started. Any way managed to drive home with his battery pack plugged into battery. Also had engine management light on. To cut a long story sort. The AA chap said I know what the problem is it’s a bad earth to the battery. He’s relocated the earth and checked battery all ok (before he fixed the problem the battery was only pulling 1.5amp now fixed Over 50amp. He said there’s a recall for this issue. I can’t see anything on topex. (Has anyone else had this problem) by the way this is a 2020 HSE lux.
    This could have ended up has a big incredibly expensive insurance clam it has happened on the motorway. It worth thinking off.
  • Blackfly
    Member Since: 15 Jun 2017
    Location: Up North
    Posts: 451
    Canada 
    2017 Discovery Td6 HSE Indus Silver

    I had a dead battery on my 2017, related then everything goes dead within a few days of the replacement. Various cables re0laced, had no issues since. This is from Topix. I do not have the details of the bulletin .




    F50, Fourtack, LR3 and now..............D5 HSE
  • Leo disco
    Member Since: 03 Oct 2019
    Location: North east
    Posts: 38
    United Kingdom 

    Hello all
    Had this same fault yesterday. Car not used for weeks but charged via ctek charger. Washed the and got a low battery message. Went for a short drive stopped the car and won't start. I rang assist and looked at the battery by climbing over the back seats. The main earth from the battery to the body was hot due to lose connection. I pulled it at the body end and a big spark happened as the car sprang back to life. Once home I wire brushed all the connectors and applied wd40. I think paint was preventing a good connection. So if your getting low battery messages check this out.
  • bammmy
    Member Since: 29 Jul 2018
    Location: Manchester
    Posts: 123
     

    Hi Leo Disco,
    how did you actually gain access to your battery, well worth a check.
    Cheers
    Mark
  • cariadycwm
    Member Since: 08 Mar 2020
    Location: Llangors
    Posts: 4
    Wales 

    Yes, same on my 2020 Landmark, intermittent issues with electronics failing, then dead. LR recovery found a faulty body earth terminal, the mechanic identified the fault straight away, based on my story, he had seen it on Disco4 but not a 5, temp repair then into the stealer last week for a permanent fix. No mention of a recall.
  • Leo disco
    Member Since: 03 Oct 2019
    Location: North east
    Posts: 38
    United Kingdom 

    The battery is in the boot behind the right hand side cover. Remove the cover for the jack then the panel in front of it. You will then see the battery and the ground / earth lead below it.
  • Mackers
    Member Since: 21 Sep 2020
    Location: Surrey
    Posts: 1
    United Kingdom 
    2019 Discovery Si4 HSE Corris Grey

    Another one for the earth lead problem. 2020 Landmark as well. 2 major power failures, more fortunately parked safely on both, but absolutely no power to car (even remote didn’t work), couldn’t get kids and dog out of rear of car due doors locked.
    Attended by same Land Rover Assist mechanic on both occasions, nice guy. On the first breakdown and on hearing my issues went straight for the earth lead, felt it to be very hot. Tightened it all up (mentioned connection was loose), all operates normally for a week. 2nd breakdown a week later, same guy is confused, still earth lead issues, makes a temporary repair and gets me on the road to local LR garage for repair. Disco in the garage for 2 weeks, with loan car via LR Assist. A week after picking up, so far so good, also seems to have addressed the random failure messages I got from various safety features on a number of occasions. Did have to get the garage to repair the usb charging sockets which had lost power whilst in garage, another loose connection.... Starting to get worried I have a Friday afternoon special, ongoing conversations with LR ‘Customer Experience’ Team for some service recovery..! This is obviously not a random problem but a widespread manufacturing problem.
  • mack1979
    Member Since: 07 Aug 2017
    Location: Amersham
    Posts: 23
    United Kingdom 
    2019 Discovery SDV6 HSE Santorini Black

    Similar here, 20MY HSE. Loads of electrical warnings, battery low constantly. LR assist came out, said he was the first person to identify this loose earth issue. Took the earth point from it's current position (apparently this was a 17MY issue, fixed in-between then reintroduced for 20MY) to a spare earth point in the same area. That made it work better for a week or two but now I am getting constantly low battery. Left it running for an hour, low battery went away for one use but when I parked up again it is killing even interior lights.

    As the car is still starting LR assist don't want to do anything. Dealer can't book it in until mid January. Loads of features which just don't work including subscription things like remote control, but basic things like cruise.

    New D5 HSE 3l sd6 20 plate MY20. Black and all the black options!
    Old: (for sale) D4 MY11 3.0l sdv6 (black obviously)
  • Leo disco
    Member Since: 03 Oct 2019
    Location: North east
    Posts: 38
    United Kingdom 

    Hi Mack I feel your pain. These cars don't like have a faulty power source it messes with the ECU'S. My dealer got it straight in to fix this know issue, it should have been a recall. They rivet a new earth post on the car body the old one is faulty. The battery also gets damaged due to the loose connection (probably your issue) . The dealer did a 'restore' on the battery and said it was good but my CTEK charger showed it as faulty. I also had an issue with the electric seats not working properly. The dealer had to reset the seat ecu. Eventually after multiple attempts my CTEK charger fixed the battery on restore in AGM mode. Get a CTEK and give it a go.
  • Equilibrium
    Member Since: 26 Feb 2019
    Location: Bristol
    Posts: 470
    United Kingdom 
    2019 Discovery SDV6 HSE Lux Carpathian Grey

    mack1979 wrote:
    Similar here, 20MY HSE. Loads of electrical warnings, battery low constantly. LR assist came out, said he was the first person to identify this loose earth issue. Took the earth point from it's current position (apparently this was a 17MY issue, fixed in-between then reintroduced for 20MY) to a spare earth point in the same area. That made it work better for a week or two but now I am getting constantly low battery. Left it running for an hour, low battery went away for one use but when I parked up again it is killing even interior lights.

    As the car is still starting LR assist don't want to do anything. Dealer can't book it in until mid January. Loads of features which just don't work including subscription things like remote control, but basic things like cruise.

    "Hello LR Assist, the problem has got worse and now the vehicle won't start"

    Hopefully, there is no way that the excellent assist mechanics won't investigate even if it happens to coincidentally start when they try it. Features not working is a safety issue, mine went into a dealer via Assist twice, on both occasions the problems were not occurring when they attended but the raft of assistance sytsem failures were showing via OBD.

    Good luck Smile I'm 12 months on from building a deep bond with LR Assist and hoping to make it through Xmas with my own car this time around. The day before Xmas eve last year was a mini-tour for me and my daughter. Dropping my own car at Bristol, taking an Assist-funded cab to the Bath dealer and then a nice trip home in the fresh loaner. (Bristol had no loaner available, hence the two dealer tour).

    Drives: 2020 MY20 HSE Luxury SDV6 in Eiger Grey/Glacier
    Departed: 2019 MY20 HSE Luxury SDV6 in Carpathian Grey/Glacier, 440i, 320d, Toyotas, Mondeo, Citroen BX amongst others
  • Leo disco
    Member Since: 03 Oct 2019
    Location: North east
    Posts: 38
    United Kingdom 

    Hi just noticed your comment about a spare earth terminal in the same area. If this is the trim 6mn stud its not man enough for the whole car current and may be the reason things aren't working. Only a newly riveted stud will fix this issue.
  • mack1979
    Member Since: 07 Aug 2017
    Location: Amersham
    Posts: 23
    United Kingdom 
    2019 Discovery SDV6 HSE Santorini Black

    Thanks all for the helpful replies. I'll give LR Assist another go, then try the ctek.

    New D5 HSE 3l sd6 20 plate MY20. Black and all the black options!
    Old: (for sale) D4 MY11 3.0l sdv6 (black obviously)
  • Hessel
    Member Since: 10 Feb 2017
    Location: Worcetershire
    Posts: 18
    England 
    2019 Discovery SDV6 HSE Lux Santorini Black

    Landrover has released a recall today for this issue. Very Happy

    1 outstanding campaign(s) for this vehicle.
    N400 - STARTUP BATTERY GROUND STUD - POOR CONNECTION
    N400 - Startup Battery Ground Stud - Insufficient Ground Contact.
  • Blackfly
    Member Since: 15 Jun 2017
    Location: Up North
    Posts: 451
    Canada 
    2017 Discovery Td6 HSE Indus Silver

    My issues were almost over a year ago! I suppose you want to be sure before you issue a recall Sheep

    F50, Fourtack, LR3 and now..............D5 HSE
  • mack1979
    Member Since: 07 Aug 2017
    Location: Amersham
    Posts: 23
    United Kingdom 
    2019 Discovery SDV6 HSE Santorini Black

    Hessel wrote:
    Landrover has released a recall today for this issue. Very Happy

    1 outstanding campaign(s) for this vehicle.
    N400 - STARTUP BATTERY GROUND STUD - POOR CONNECTION
    N400 - Startup Battery Ground Stud - Insufficient Ground Contact.


    That's frustrating. They finally took my car in last week and had it 6th-8th. They replaced the battery, but said the earth stud would need rebooking as they can't get the new stud from LR until Feb. Oh well, at least now I know it will definitely get done.

    New D5 HSE 3l sd6 20 plate MY20. Black and all the black options!
    Old: (for sale) D4 MY11 3.0l sdv6 (black obviously)
  • Forum Permissions
  • You cannot create new threads in this forum
    You cannot reply to threads in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot vote in polls in this forum
All times are GMT DISCO5.CO.UK © 2016 - 2021 Futuranet Ltd DISCO5.CO.UK RSS Feed - All Forums 
DISCO5.CO.UK is independent and not affiliated to Jaguar Land Rover.
Switch to the mobile site